Firefox 2.0 and Existing Plugins/Extensions

Posted by & filed under , , .

So Firefox 2.0 has been out for a while. However, if you check out some of the release notes, the one that talks about updating extensions for Firefox 2 seems really interesting:

The first step — and, for most extensions, the only one that will be needed — is to update the install manifest file, install.rdf, to indicate compatibility with Firefox 2. Simply find the line indicating the maximum compatible version of Firefox (which, for Firefox 1.5, might look like this: <em:maxVersion>1.5.0.*</em:maxVersion> Change it to indicate compatibility with Firefox 2: <em:maxVersion>2.0.0.*</em:maxVersion> Then reinstall your extension.

All seems cool — after all that doesn’t seem too much to ask. However, having checked the extensions that I have currently on my Firefox 1.5, it turns out a lot of them have these value: <em:maxVersion>1.5+</em:maxVersion> !

Strangely enough that is not recognized by Firefox 2.0 as a valid version (even though it was recognized as such by Firefox 1.5!) so because of this Firefox 2.0 rejects the extension as incompatible and disables it. Well, since this is the case with a lot of the extensions I use, that means that simply upgrading my Firefox to 2.0 will render these extensions useless at least until the developer decides to update the description file and put it through QA with mozdev.org and it gets re-approved.

So word to all of you out there: if you rely a lot on your Firefox extensions, I’d give it a bit more time before upgrading to Firefox 2.0!

Leave a Reply

Your email address will not be published.